martes, 6 de diciembre de 2011

Configuración OSPF para redes Cisco


En éste ejercicio vamos a configurar el protocolo de enrutamiento OSPF, para lo cual vamos a utilizar la red sin clase de la topología en la cual hay varias redes cada una  mascaras diferentes, vamos a partir con la configuración básica de los routers y los PC ya configurada es decir todas las interfaces de routers y PC ya están configuradas previamente si tiene algun problema con ello revise temas anteriores y lo podra hacer sin dificultad. También vamos a insistir en la ruta estática por defecto dada la importancia de la misma para lo cual nos vamos a ayudar de las interfaces de loopback de los routers para simular un router virtual ISP.

CONFIGURACION OSPF ROUTER1

R1#sh ip interf brief
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        172.16.1.17     YES manual up                    up

FastEthernet0/1        unassigned      YES unset  administratively down down

Serial0/0/0            192.168.10.1    YES manual up                    up

Serial0/0/1            192.168.10.5    YES manual up                    up

Vlan1                  unassigned      YES unset  administratively down down

R1#sh ip route

     172.16.0.0/28 is subnetted, 1 subnets
C       172.16.1.16 is directly connected, FastEthernet0/0
     192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.0 is directly connected, Serial0/0/0
C       192.168.10.4 is directly connected, Serial0/0/1
 
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router ospf 1
R1(config-router)#network 172.16.1.16 0.0.0.15 area 0
R1(config-router)#network 192.168.10.0 0.0.0.3 area 0
R1(config-router)#network 192.168.10.4 0.0.0.3 area 0
R1(config-router)#^Z
%SYS-5-CONFIG_I: Configured from console by console
R1#
R1#write
Building configuration...
[OK]
R1#
R1#sh ip route

     10.0.0.0/24 is subnetted, 1 subnets
O       10.10.10.0 [110/1172] via 192.168.10.6, 00:01:16, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.1.16/28 is directly connected, FastEthernet0/0
O       172.16.1.32/29 [110/391] via 192.168.10.6, 00:01:26, Serial0/0/1
     192.168.10.0/30 is subnetted, 3 subnets
C       192.168.10.0 is directly connected, Serial0/0/0
C       192.168.10.4 is directly connected, Serial0/0/1
O       192.168.10.8 [110/1171] via 192.168.10.6, 00:01:26, Serial0/0/1


CONFIGURACION OSPF ROUTER2

R2#sh ip interf brief
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        10.10.10.1      YES manual up                    up

FastEthernet0/1        unassigned      YES unset  administratively down down

Serial0/0/0            192.168.10.2    YES manual up                    up

Serial0/0/1            192.168.10.9    YES manual up                    up

Vlan1                  unassigned      YES unset  administratively down down
R2#sh ip route
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
     192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.0 is directly connected, Serial0/0/0
C       192.168.10.8 is directly connected, Serial0/0/1
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router ospf 1
R2(config-router)#network 10.10.10.0 0.0.0.255 area 0
R2(config-router)#network 192.168.10.0 0.0.0.3 area 0
R2(config-router)#network 192.168.10.8 0.0.0.3 area 0
R2(config-router)#^Z
R2#
R2#sh ip route

     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.16.1.16/28 [110/1172] via 192.168.10.10, 00:01:56, Serial0/0/1
O       172.16.1.32/29 [110/782] via 192.168.10.10, 00:01:56, Serial0/0/1
     192.168.10.0/30 is subnetted, 3 subnets
C       192.168.10.0 is directly connected, Serial0/0/0
O       192.168.10.4 [110/1171] via 192.168.10.10, 00:01:56, Serial0/0/1
C       192.168.10.8 is directly connected, Serial0/0/1

CONFIGURACION OSPF ROUTER 3

R3#sh ip interf brief
Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        172.16.1.33     YES manual up                    up

FastEthernet0/1        unassigned      YES unset  administratively down down

Serial0/0/0            192.168.10.6    YES manual up                    up

Serial0/0/1            192.168.10.10   YES manual up                    up

Vlan1                  unassigned      YES unset  administratively down down

R3#sh ip route
     172.16.0.0/29 is subnetted, 1 subnets
C       172.16.1.32 is directly connected, FastEthernet0/0
     192.168.10.0/30 is subnetted, 2 subnets
C       192.168.10.4 is directly connected, Serial0/0/0
C       192.168.10.8 is directly connected, Serial0/0/1
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router ospf 1
R3(config-router)#network 172.16.1.32 0.0.0.7 area 0
R3(config-router)#network 192.168.10.4 0.0.0.3 area 0
R3(config-router)#network 192.168.10.8 0.0.0.3 area 0
00:33:05: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.5 on Serial0/0/0 from LOADING to FULL, Loading Done

R3(config-router)#
00:33:17: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.9 on Serial0/0/1 from EXCHANGE to FULL, Exchange Done
^Z

%SYS-5-CONFIG_I: Configured from console by console
R3#
R3#sh ip route

     10.0.0.0/24 is subnetted, 1 subnets
O       10.10.10.0 [110/782] via 192.168.10.9, 00:02:33, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.16.1.16/28 [110/391] via 192.168.10.5, 00:02:43, Serial0/0/0
C       172.16.1.32/29 is directly connected, FastEthernet0/0
     192.168.10.0/30 is subnetted, 3 subnets
O       192.168.10.0 [110/1952] via 192.168.10.5, 00:02:43, Serial0/0/0
C       192.168.10.4 is directly connected, Serial0/0/0
C       192.168.10.8 is directly connected, Serial0/0/1
R3#
R3#sh ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.10.10
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.1.32 0.0.0.7 area 0
    192.168.10.4 0.0.0.3 area 0
    192.168.10.8 0.0.0.3 area 0
  Routing Information Sources: 
    Gateway         Distance      Last Update
    192.168.10.5         110      00:03:30
    192.168.10.9         110      00:03:30
  Distance: (default is 110)
R3#sh ip ospf
 Routing Process "ospf 1" with ID 192.168.10.10
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 3
        Area has no authentication
        SPF algorithm executed 4 times
        Area ranges are
        Number of LSA 3. Checksum Sum 0x01f05d
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

R3#sh ip ospf interface
FastEthernet0/0 is up, line protocol is up
  Internet address is 172.16.1.33/29, Area 0
  Process ID 1, Router ID 192.168.10.10, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 192.168.10.10, Interface address 172.16.1.33
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
Serial0/0/0 is up, line protocol is up
  Internet address is 192.168.10.6/30, Area 0
  Process ID 1, Router ID 192.168.10.10, Network Type POINT-TO-POINT, Cost: 390
  Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0
  No designated router on this network
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:01
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1 , Adjacent neighbor count is 1
    Adjacent with neighbor 192.168.10.5
  Suppress hello for 0 neighbor(s)
Serial0/0/1 is up, line protocol is up
  Internet address is 192.168.10.10/30, Area 0
  Process ID 1, Router ID 192.168.10.10, Network Type POINT-TO-POINT, Cost: 781
  Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0
  No designated router on this network
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1 , Adjacent neighbor count is 1
    Adjacent with neighbor 192.168.10.9
  Suppress hello for 0 neighbor(s)
R3#

CONFIGURACION DE LA RUTA POR DEFECTO

R1(config)#interf loopback 1
%LINK-5-CHANGED: Interface Loopback1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up

R1(config-if)#ip add 172.30.1.1 255.255.255.252
R1(config-if)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 loopback 1
R1(config)#router ospf 1
R1(config-router)#default-information originate

R2#sh ip route
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.2.2.2/32 is directly connected, Loopback0
C       10.10.10.0/24 is directly connected, FastEthernet0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.16.1.16/28 [110/1563] via 192.168.10.1, 00:07:00, Serial0/0/0
O       172.16.1.32/29 [110/1563] via 192.168.10.10, 00:07:00, Serial0/0/1
     192.168.10.0/30 is subnetted, 3 subnets
C       192.168.10.0 is directly connected, Serial0/0/0
O       192.168.10.4 [110/3124] via 192.168.10.10, 00:04:28, Serial0/0/1
                     [110/3124] via 192.168.10.1, 00:04:28, Serial0/0/0
C       192.168.10.8 is directly connected, Serial0/0/1
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 00:01:06, Serial0/0/0
R2#
Para verificar la configuración haga:
PC1>Ping 10.10.10.10
PC1>Ping 172.16.1.35
vera q son satisfactorios y q OSPF funciona perfectamente

No hay comentarios:

Publicar un comentario en la entrada